SEV-3 (Medium) TSYS System Incident - TSYS InfoCenter inaccessible
Incident Report for Global Payments
Resolved
This incident was resolved at 12:41 MDT when a TSYS InfoCenter load issue was corrected. Teams will be working on steps for remediation and prevention of future occurrences.
Posted Oct 15, 2020 - 13:43 MDT
Identified
Our team has identified an issue with TSYS InfoCenter and are taking steps to correct situation. We are continuing to investigate and monitor.

Our teams are working to resolve the issue as quickly as possible.
We will provide regular updates until the situation is corrected.
Posted Oct 15, 2020 - 12:46 MDT
Investigating
We are aware of an issue with TSYS InfoCenter being inaccessible and we are investigating this matter further.

Our teams are working to resolve the issue as quickly as possible.
We will provide regular updates until the situation is corrected.
Posted Oct 15, 2020 - 11:35 MDT
This incident affected: TSYS InfoCenter.