Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 07, 2026 - 23:00 MDT
Update
Please see the below maintenance advisory regarding EI - TaaS # PROD TaaS 2.0 DR Activity scheduled for April 8, 2026. Please note that this maintenance has been rescheduled from April 7th to April 8th.
Scheduled Maintenance: EI - TaaS # PROD TaaS 2.0 DR Activity Effective April 8, 2026
Please be advised Global Payments will be performing EI - TaaS # PROD TaaS 2.0 DR Activity on Tuesday, April 8, 2026. This maintenance is scheduled to begin at 01:00 A.M. ET and end at 08:00 A.M. ET the same day. During the maintenance window we do not expect any impact. If you experience any issues, please follow the established escalation procedures. As always, please do not hesitate to contact your Global Payments Relationship Manager with any questions regarding this announcement.
Posted Apr 02, 2026 - 13:01 MDT
Scheduled
Please see the below maintenance advisory regarding EI - TaaS # PROD TaaS 2.0 DR Activity scheduled for April 7, 2026.
Scheduled Maintenance: EI - TaaS # PROD TaaS 2.0 DR Activity Effective April 7, 2026
Please be advised Global Payments will be performing EI - TaaS # PROD TaaS 2.0 DR Activity on Tuesday, April 7, 2026. This maintenance is scheduled to begin at 12:00 A.M. ET and end at 07:00 A.M. ET the same day. During the maintenance window we do not expect any impact. If you experience any issues, please follow the established escalation procedures.
As always, please do not hesitate to contact your Global Payments Relationship Manager with any questions regarding this announcement.
Posted Mar 31, 2026 - 12:56 MDT
This scheduled maintenance affected: Global Payments - Canada (Portico Canada ATL/RIC, Portico Canada GCP, GPAPI Canada).